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Conventions Used in this Guide
Please take a moment to review how instructions and other useful information are presented in
this guide.
« Procedures are presented as numbered lists. A single bullet indicates that the procedure
has only one step.
» Bold type is used for the following:

o Keyboard entries that should be typed in their entirety exactly as shown. For example,
“copy file1” means the word copy must be typed, then a space must be typed, and then
file1 must be typed.

o On-screen prompts and messages, names of options and text boxes, and menu com-
mands. Menu commands are often separated by carats. For example, “click HFSS>Exci-
tations>Assign>Wave Port.”

o Labeled keys on the computer keyboard. For example, “Press Enter” means to press the
key labeled Enter.

« ltalic type is used for the following:
o Emphasis.
o The titles of publications.
o Keyboard entries when a name or a variable must be typed in place of the words in italics.

For example, “copy file name” the word copy must be typed, then a space must be
typed, and then name of the file must be typed.

« The plus sign (+) is used between keyboard keys to indicate that you should press the keys
at the same time. For example, “Press Shift+F1” means to press the Shift key and the F1
key at the same time.

« Toolbar buttons serve as shortcuts for executing commands. Toolbar buttons are displayed
after the command they execute. For example,

“On the Draw menu, click Line N

to execute the Line command.
Getting Help: ANSYS Technical Support
For information about ANSY'S Technical Support, go to the ANSYS corporate Support website,

http://www.ansys.com/Support. You can also contact your ANSYS account manager in order to
obtain this information.

” means that you can click the Draw Line toolbar button

AllANSYS software files are ASCII text and can be sent conveniently by e-mail. When reporting
difficulties, it is extremely helpful to include very specific information about what steps were taken
or what stages the simulation reached, including software files as applicable. This allows more
rapid and effective debugging.

Help Menu

To access online help from the menu bar, click Help and select from the menu:
Contents - click here to open the contents of the online help.

Search - click here to open the search function of the online help.
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Context-Sensitive Help
To access online help from the user interface, do one of the following:

« Toopen ahelp topic about a specific menu command, press Shift+F1, and then click the
command or toolbar icon.

« Toopen a help topic about a specific dialog box, open the dialog box, and then press F1.
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1 - Introduction

This document is intended as supplementary material to HFSS users. We assume you have some
experience of designing projects using HFSS. This tutorial includes instructions to create, solve,
and analyze results of models that use a Floquet port.

This chapter contains the following topics:
v General Outline

v  Floquet Portsin HFSS

General Outline

This tutorial teaches you how to perform the following tasks in HFSS:
o Create the geometric models.
« Modify the models’ design parameters.
« Specify solution setup and sweep for the designs.
» Validate the design setups.
o Run HFSS simulations.
« Create 2D x-y plots of S-parameter results.

Floquet Ports in HFSS

The Floquet portin HFSS is used exclusively with planar-periedic structures. Chief examples are
planar phased arrays and frequency selective surfaces when these may be idealized as infinitely
large. The analysis of the infinite structure is then accomplished by analyzing a unit cell. Linked
boundaries most often form the side walls of a unit cell, but in addition, a boundary condition is
required to account for the infinite space above. The Floquet port is designed for this purpose.

The Floquet port is closely related to a Wave port in that a set of modes (“Floquet modes”) rep-
resents the fields on the port boundary. Fundamentally, Floquet modes are plane waves with
propagation direction set by the frequency, phasing, and geometry of the periodic structure. Just
like Wave modes, Floquet modes too have propagation constants and experience cut-off at low fre-
quency.

When a Floquet port is present, the HFSS solution includes a modal decomposition that gives addi-
tional information on the performance of the radiating structure. As in the case of a Wave port, this
information is cast in the form of an S-matrix interrelating the Floquet modes. In fact, if Floquet
ports and Wave ports are simultaneously present, the S-matrix will interrelate all Wave modes and
all Floquet modes in the project.

For the current version, the following restrictions apply:
« Currently, only modal projects may contain Floquet ports.
« Boundaries that are adjacent to a Floquet port must be linked boundaries.
« Fastfrequency sweep is not supported. (Discrete and interpolating sweep are supported.)

Introduction 1-1
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2

This chapter contains the following topics:

Sample Project - Array Antenna

Set Units and Solution Type

Create the Unit Cell Model

Assign Master and Slave Boundaries
Direction of the U-V Vectors
Assigning Wave Ports

Assign Wave Port with Analytical Mode Alignment
Assign Floquet Port

Floquet Port Dialog Box

Add Solution Setup

Run Simulation and View Results
Create Variables for Scan Angles
Use Scan Angles for the Model
Parametric Sweep of Scan Angle

Set up Modes for Parametric Sweep
Viewing Results of Parametric Sweep
Generate Reports

Sample Project - Array Antenna

"Array Antenna" on the next page. illustrates an infinite array of square aperture antennas in a con-
ducting plane. The elements are fed from below the plane by square waveguide ports with dom-
inant modal field aligned in the direction shown.

- Array Antennas

Array Antennas 2-1
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Figure 2-1 Array Antenna

When the elements are uniformly excited so that the array radiates in the broadside direction, the
field above the array is periodic. The relative positions of the periodic points where field values are
equal may be specified by a pair of vectors, shown in blue and denoted by a and b. These “lattice
vectors" describe the geometry of the array but are independent of the nature of the array ele-
ments themselves. The lattice vectors may be parallel-transported anywhere in the array plane to
show corresponding field points.

In the usual way, a unit cell may be analyzed to represent the entire array and the outline of one
possible unit cell is shown in "Array Antenna" above. using dotted lines.

"HFSS model of unit cell with lattice vectors " on the facing page. depicts an HFSS model for the
unit cell of the infinite array. The model consists of two boxes. The lower box represents the feed-
ing waveguide and the top box is the unit cell for the region above the plane. The dimensions and
geometry of the unit cell reflect the lattice vectors of the array. Linked boundaries are defined on
the cell walls and a Wave port provides the array element excitation.

Array Antennas 2-2
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Figure 2-2 HFSS model of unit cell with lattice vectors

Note A Floquet port is used on the (top) open boundary.

Set Units and Solution Type

Set the units and solution type for this project before you design the model.

1.

o0k wbd

Open a new Project and name it rhombicArray.

Click Modeler>Units and set the units to cmand click OK.
Insertan HFSS design type.

Click HFSS>Solution Type.

Select Modal.

Click OK.

Create the Unit Cell Model for the Array Antenna

1.

Click Draw>Box to create an arbitrary box and edit the fields in the Properties dialog box

as in "Command tab of the Properties dialog box" on the next page. .

Array Antennas 2-3
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MName | Value Lnit Evaluated Value
Command CreateBox
N Coordinate Sys... Global
| Postion 0.33645 033645 0 meter -0.33645meter , -0.33645meter , Ometer
[ %Size 06725 meter 0.6729meter
- |YSize 06725 meter 0.6729meter
- |ZSize 14 meter 1.4meter

Figure 2-3 Command tab of the Properties dialog box

2. Select the newly created box, and change Transparency to 0.86.
3. Click Draw>Box to create a second arbitrary box, and edit the fields as in "Command tab for

the second box." below. .

Evaluated Value

Mame | Walue | Linit
Command CreateBox
N Coordinate Sys... Global
| |Posttion 0.3119.0.3119.0 meter
| XSize 06238 meter
- [YSize 06232 meter
| ZSize -1.4 meter

-0.3119meter , -0.3119meter , Ometer
0.6238meter

0.6238meter

-1 dmeter

Figure 2-4 Command tab for the second box.

Z

T

Figure 2-5 The Unit Cell Model
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Assign Master and Slave Boundaries

Assign boundaries to the box object as follows.

. Hit F to enter face selection mode.

2. Selectthe face (see "U Vector drawn" on the next page. ) of the first box, and click

HFSS>Boundaries>Assign>Master.
The Master Boundary dialog box appears.

Master Boundary

Mame: |Mazter]

Coordinate System

I “ectar | Defined ﬂ

W o Vector [ Reverse Direction

Figure 2-6 Master Boundary dialog
. Select New Vector from the U-Vector drop-down menu.
Note Leave the default Name as Master1.

The Measure Data and Create Line dialog boxes appear.

Note Measure Data will show up only if you have checked “Show measure dialog” on the
Drawing tab of the Modeler Options (under Tools) dialog box.

. Click the lower right-most corner of the face and draw the U vector (red arrow) along the left.
See "U Vector drawn" on the next page. .

Note Draw the vector from right to left.

Array Antennas 2-5
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Mame: [Master]

— Coordinate Svstem

I ectar:

YW Vector [ Fewerse Direction

Figure 2-7 U Vector drawn

5. Click OK.
The Master 1 boundary gets assigned. See "Boundary applied" below. .

|

Figure 2-8 Boundary applied

6. Press Alt and rotate the box 180 degrees to access the face opposite to Master1. See "Face
with the prospective Slave1 boundary" on the facing page. .

Note You can also select another face, and hit B to access the desired face.

7. Click HFSS > Boundaries > Assign > Slave.
The Slave: General Data dialog box appears.

Array Antennas 2-6
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8.
9.

10.

11.

12.

13.

Figure 2-9 Face with the prospective Slave1 boundary

Select Master 1 on the Master Boundary drop-down menu.
Select New Vector on the U Vector drop-down menu.

Note Leave Name as Slave1.

The Measure Data and the Create Line dialog boxes appear with the cursor holding the
dotted line.

Click the left-most corner of the face and drag the cursor to the right-most corner, click,
again.

Note Remember the direction of the U-V vectors for the Master must be the same for its cor-
responding Slave.

The Slave: General Data dialog appears with the U and V vectors applied.

Verify that the option Reverse Direction of V-Vector is checked.

Note The U-Vector field should show as Defined now.

Click Next.

The Slave: Phase Delay dialog box appears.
Click Finish.

The Slave1 boundary is assigned.

Array Antennas 2-7
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14.

15.
16.

17.

Figure 2-10 The Slave1 boundary is assigned.

Right click the face on the right side of Slave 7 and select Assign Boundary> Master from
the short-cut menu.

The Master Boundary dialog box appears.
Select New Vector on the U-Vector drop-down menu.

Click the leftmost corner of the face and drag the cursor to the rightmost corner to draw the
U-Vector.

The U-vector arrow is applied whereas the V-vector arrow points downwards. See "The V-
Vector pointing downwards." on the facing page. and "Master Boundary" on the facing
page. .

Check V-Vector Reverse Direction as in "Master Boundary" on the facing page. .

Note You need to reverse the direction of the V-Vector to include it on the box and not out-
side of it. For more information, see the next section.

Array Antennas 2-8
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18.
19.

20.
21.

22.

Figure 2-11 The V-Vector pointing downwards.

M arne: IMasterE

— Coordinate Spstem

I Wector: I Defined LI

Y “ector |V Reverse Direction

Figure 2-12 Master Boundary

Check V Vector:Reverse Direction.

Click OK.

The direction of the V-Vector is reversed and the boundary Master2 is applied.
Rotate the box 180 degrees to access the face opposite to Master 2.

Right click> Assign Boundary >Slave.

The Slave: General Data dialog box appears.

Select Master2 as the Boundary and New Vector as the U Vector.

Array Antennas 2-9
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The Create Line and Measure Data boxes occur.

23. Click the rightmost corner of the face and drag the cursor to the left most corner, click and
then, release.

The Slave: General Data dialog box appears.
24. Click Next.
The Slave: Phase Delay dialog box appears.

(¥ |ze Scan Angles To Calculate Phase Delay

Scan Angles
Phi: | 0 |deg ﬂ
Theta: | 0 |deg ﬂ

(Applies to whole model, in the global coordinate system)

" Input Phase Delay

E

=]
[41]
=]

Figure 2-13 Phase Delay

25. Accept the default settings and click Finish.
The Slave2 boundary is assigned.

Direction of the U-V Vectors

HFSS uses the U-V vectors to set up a local co-ordinate system. A point on the Master boundary
must correspond to that on the Slave. A point on the Slave needs to be paired on the Master so
that a one-to-one correspondence can be established. Such a co-ordinate system should be con-
structed and aligned properly in the same direction so that the mapping is accomplished suc-
cessfully. Therefore, when the V-vector is directed downwards, you must check the “Reverse
Direction” option to keep it on the face of the box and not pointing outside of it.

Assigning Wave Ports

HFSS offers you both Integration lines and a localized co-ordinate system to assign Wave ports.
When assigning a wave port HFSS generates a Wave Port: Modes dialog box with options to
help set-up the Mode Alignment and Polarity. A portion of this dialog box is shown in "Portion of
the Wave Port: Mode dialog box" on the facing page. .

Array Antennas 2-10
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Mode Alignment and Paolarity:
(" Set mode polanty using irtegration lines
(" Align modes using integration lines
* Align modes anahtically using coordinate system
Ul fodis |L|nu:|efineu:| ﬂ [ Reverse V Direction

Figure 2-14 Portion of the Wave Port: Mode dialog box
Note This dialog box will appear only while you assign Wave ports.

For this particular design i.e. the cell model with emphasis on Floquet ports, we recommend you
assign the Wave port with analytical mode alignment. The last radio button in "Portion of the Wave
Port: Mode dialog box" above. should be selected for this project.

Note For more information, see the online help.

Assign Wave Port with Analytical Mode Alignment
A Wave port boundary will be assigned to the bottom surface of the feeding waveguide to model
the energy injected into the array element.
1. Select the bottom face of the lower box. See "Wave Ports assigned on the bottom face" on
page 2-13..
2. Right-click, and from the shortcut menu, select Assign Excitations > Wave Port.
The Wave Port: General dialog box appears.
3. Enter awave portin the Name field and click Next.
The Wave Port: Modes dialog box appears.
4. Make the following entries:
« Enter Number of Modes as 2.
Note Because the feeding waveguide has a square cross section, two waveguide modes
must be specified.
« Select the radio button “Align Modes analytically using co-ordinate system.”
« Select “New Vector’ from the U Axis drop-down menu.

Array Antennas 2-11
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Wave Port : Modes P

Mumber of Modes: |2

Made | Integration Line | Charactenstic Impedance (o)
MNone Zpi
2 MNaone Zpi

Mode Alignment and Polarity:
(" Set mode polanty using irtegration lines
(" Mlign modes using integration lines
* Align modes analytically using coordinate system
U fodis |Defineu:| j [ Rewverse V Direction

[ Filter modes for reporter

|se Defaults

< Back Mext = Cancel

Figure 2-15 Wave Port: Modes Dialog Box - see blue-ink that highlights the radio button.

The cursor with a dotted line appears.
5. Click the mid point of a side (nearest to the X axis) of the bottom face.
A small opaque triangle and mini axes appear.

6. Draw the line by following the horizontal mini axis (perpendicular to the X axis and therefore,
parallel to the Y axis. See "Wave Ports assigned on the bottom face" on the facing page. .

Array Antennas 2-12
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Figure 2-16 Wave Ports assigned on the bottom face

The Wave Port: Modes dialog box appears.

. Select “Reverse V Direction.”

V vector points in the direction of the positive Y-axis.

. Click Next on the Wave Port: Modes dialog box.

The Wave Port: Post Processing dialog box appears.

. Verify that the default settings are as shown in "Wave Port: Post Processing" on the next
page. .

Array Antennas 2-13
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Wave Port : Post Processing

— Port Renomalization
* Do Mot Renomalize

™ Renomalize &l Modes
Full Port Impedance: 50 Iu:uhm LI

" Renomalize Specific Modes Edit tode Impedances. .. |

— Deembed Settings

[T Deembed Chztance: |0 Imm j

Pozitive diztance will deembed into the part,

Get Distance Graphically... |

Figure 2-17 Wave Port: Post Processing

10. Click Finish.

The excitation is assigned and a wave port occurs under Excitations on the Project Man-
ager window.

----- B8 Mesh Operations
..... S Analysis
8] Optimetrics

m-F Port Field Display

..... TG Field Overays
----- % Radiation

Figure 2-18 Wave Ports assigned

Assign Floquet Port

To assign the Floquet port perform the following steps.

Array Antennas 2-14
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1. Select the top face of the upper box.
2. Rightclick, and select Assign > Excitation > Floquet Port from the shortcut menu.
The Floquet Port: General dialog box appears and the top face gets labeled as Flo-

-~

Floquet Port : General

MName: FloguetPort 1

Lattice Coordinate System

& Direction: Iundeﬁned

E Direction: Il,_lndeﬁned

quetPort1.
Figure 2-19 Floquet Port: General dialog box

3. Onthe Lattice Coordinate System, select New Vector for the A Direction.
The cursor with the new dotted line appears on the Modeler window.

4. Draw the A-Direction vector parallel to the X-axis with the arrow in the same direction that
of the positive x-axis.

The “a” vector is drawn and the Floquet Port: General dialog appears.

-

Floquet Port : General

MName: Fluquet Port 1

Lattice Coordinate System

A Direction: IDeﬁned

L]

B Direction: IDeﬁned

L

Figure 2-20 Floquet ports assigned
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5. Select New Vectorfrom the B-Direction drop-down.
6. Draw the B vector perpendicular to the A vector.
The Floquet Port: General dialog box showing both the vectors as “Defined” recurs.

Note The lattice vectors a and b must have a common origin.

7. Click Next.
The Floquet Port: Modes Setup dialog box appears.

Flequet Port: Modes Setup 2

MWumber of Modes: |2

(Please click on this buttan if you want assistance in setting up modes )

Meodes Calculatar. .. |
Made Polarization State | m | n | Attenuation {dblength)
1 TE ] 0 0.00
2 TM 1] 0 0.00

Figure 2-21 Modes Set up

8. Click Next.
The Post Processing dialog box appears.

Deembed Settings

[~ Deembed ( |mm J

|Ise Defaults

Figure 2-22 M>Post Processing

9. Verify that the Deembed box is unchecked and click Next.
The 3 D Refinement dialog box appears.

Array Antennas 2-16
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Flequet Part: 30 Refinement

To add a Foguet mode to the 30 adaptive mesh
refinement process, check the comesponding box.

In general, only add Foguet modes when these modes create
the 30 fields of interest. See the online help for details.

| Mode

Polarization State

n | AMfects Refinement |

-

10. Click Finish.

TE
™

=
—

Figure 2-23 Floquet Port: 3-D Refinement

The Floquet port is assigned and FloquetPort1 appears in the Project Manager window

under Excitations.

ﬁ Analysis
{9 Optimetrics
Results
=-[# Port Field Display
El aWaveport

m

B-If] FloquetPort1
- Mode 1
- Maode 2

-

Figure 2-24 Figure 24. Floquet Port Assigned

Floquet Port Dialog Box

While assigning the Floquet Ports, you used the different options available on the Floquet Port dia-
log box. The following sections describe the settings on each of these tabs.

Floquet Port: Mode Setup

See "Modes Set up" on the previous page. Floquet modes are specified by two modal indiees and
a polarization setting. These designations resemble the textbook notation for rectangular wave-
guide modes, such as "TE 4¢". The Floquet field patterns are different, however.
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The Floquet modes in the modes table both have modal indiees m and n equal to zero. They are
sometimes called “specular” modes. In this project, the specular modes consist of two ortho-
gonally-polarized plane waves propagating normal to the plane of the array.

Specular modes are always an essential part of the Floquet mode set. However, sometimes due
to electrical symmetry, one of the two polarizations may be omitted.

The final column of the mode table is labeled “Attenuation”. The attenuation of the mode is meas-
ured in the direction normal to the plane of the array.

The value given for the specular modes is 0 dB since they are propagating. Higher-order modes
will experience attenuation if they are cut off. The value of attenuation is greater than zero.

Note The default specular pair of modes is sufficient for this simulation.

Floquet Port: Post Processing

See "M>Post Processing" on page 2-16 . . This tab lets you specify a de-embedding distance. Just
as in a Wave port, de-embedding is an optional post processing step employed when the phase of
the S-parameter elements is of interest. The interface for de-embedding a Floquet port is the
same as that for a Wave port. For this example, we omit specifying any de-embedding.

Floquet Port: 3D Refinement

See "Floquet Port: 3-D Refinement" on the previous page. . The 3D Refinement tab controls
which Floquet modes participate in 3D adaptive mesh generation.

The default settings are such that Floquet modes will not participate in 3D adaptive refinement.

In any model with Wave, Lumped, or Floquet ports, there is a 3D modal field pattern associated
with each defined mode. This is the 3D field pattern corresponding to stimulation of the one mode,
with all other modes match terminated. The 3D mesh that is created by HFSS on subsequent
adaptive passes is actually a compromise designed to adequately represent all modal field pat-
terns simultaneously.

When a specific modal field pattern is of interest, greater solution efficiency is achieved by adapt-
ing only on the basis of the one field pattern. In the case at hand, the modal pattern corresponding
to excitation of the Wave port is of prime interest. Hence, the default setting of the 3D refinement
tab which ignores the Floquet modal field patterns in adapting the 3D mesh.

Add Solution Setup

You must add a Solution Setup for your model.
1. Right click Analysis in the Project tree, and select Add Solution Setup.
The Solution Setup dialog box appears.
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General lOptiu:uns ] Advanced ] Expression Cache | Dervatives ]

Setup Mame: |Setup'|

[+ Enabled [ Solve Ports Only

Solution Frequency: |255'.?Er |I"-'1Hz j

Adaptive Solutions

Madimum Mumber of Passes: 5

{* Madmum Detta S 0.02

Figure 2-25 Solution Setup: General

2. Enter the settings as shown in "Solution Setup: General" above. .
3. Click Options.
4. Enter the settings as in following figure.

General Options ]f-‘u:lvanu:eu:l] Expression Cache] Dervatives | De

Initial Mesh Options
I¥ Do Lambda Refinement
Lambda Target: |0.3333 v Use Default Value

[ Use Free Space Lambda

Adaptive Options
Maximum Refinemert Per Pass: 20 %
[ Maximum Refinement: 1000000

Minimum Mumber of Passes:

l'li
Minimum Converged Passes: 1

Solution Options

Order of Basis Functions: |First Cirder ﬂ

Figure 2-26 Solution Setup: Options
5. Click OK to accept the settings.
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Run Simulation and View Results

Now that you have completed the entire set-up you are ready to analyze it. Before that, be sure to
save the project.

1. Click HFSS>AnalyzeAll.

The Progress Window indicates HFSS is running the simulations. The Message Manager
indicates normal completion of the simulation if everything went off well.

2. Rightclick Results icon in the Project tree, and select Solution Data.

Simulatior; | Setup ﬂ | Lastadaphive j

Dezign Y ariation: |

Profile ] Convergence Matrix Data l Mezh Statistics ]

W S Matiz | Gamma |299_?E| [MHz] j E=port M atriz Data... |
B "r’Matri:-: [ Zo [ Display &1l Fregs. |
[ Z Matrix
|Magnitude ﬂ Check Pazsivity |
FPazsivity Tolerance: |.0001

Freq | S:awavepart:1 | S:awWaveport: 2 | S:FloquetPart]:1 |S:Fln:|quetF'n:-rt'I:2 |
W awaveport1 022227 0.00053242  0.97498 B.7476=-005
P swaveport2 000053242 0.22601 000020884 097412
B FloquetPort1:1 0.97498 0.00020884 022227 0.00054543
P FloquetPor:2 6. 74762005 0.97412 000054543 022601
]

Figure 2-27 HFSS Design Solutions

"HFSS Design Solutions" above. shows the post-simulation matrix data panel. Since phase is
unimportant for this case, only magnitudes are shown. You can select Magnitude from the drop-
down menu under Z Matrix check box. There are several things to note.

« The S-matrix is a 4x4 matrix and interrelates the wave port modes with the Floquet modes.

« The Floquet modes in the S-matrix are listed next in the order specified in the Floquet port
setup panel. By referring to this panel, we are therefore reminded that FloquetPort1:1 refers
to the TEOO Floquet mode and FloquetPort1:2 refers to the TM0O Floquet mode.

« The first column of the matrix gives the modal amplitudes for a unit stimulation of the Wave
port, i.e. the array acting in “transmit mode”. The first entry, 0.22227, is the magnitude of the
active reflection coefficient of the unit cell. The third and fourth (row) entries give the power
coupled into each of the two Floquet modes. Virtually all the non-reflected power is coupled
into the first Floquet mode. The excited Floquet mode represents a plane wave leaving the
face of the array.
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« The third and fourth columns of the S-matrix indicate the power couplings for individual excit-
ation of each of the Floquet modes. The physical picture of an exciting Floquet mode is a
plane wave incident on the infinite array from above. In the case at hand, each Floquet mode
transfers most of its power to the wave port mode with the same polarization. In these cases
think of the array acting in “receive mode”.

Create Variables for Scan Angles

Array antennas have the unique ability to redirect (scan) their energy without mechanical motion.
To include the effects of scanning in the HFSS simulation, this section will discuss parameterizing
the simulation using scan angles.

1. Onthe menu bar, click Project>Project Variables.
The Properties dialog box appears.

2. Click Project Variables and then, the Add... button.
The Add Property dialog box appears.

Add Property

M ame |$phi_su:an {* “ariablz
nit Type |N|:une j Unitz
Yalue |E||:|,jed

Figure 2-28 Add Property dialog box

3. SetName to $phi_scan, and Value = 90 deg.
4. Click OK.

The Add Property dialog box closes and the variable $phi_scan gets added on the Project
Variables window.

5. Click the Add button.

The Add Property dialog box appears again.
6. SetName to $theta scan and Value = 0 deg.
7. Click OK.

The Add Property dialog box closes and the variable $phi_scan gets added on the Project
Variables dialog box.
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Project Vaniables | intrinsic Variables | Constants |

* Value " Optimization " Tuning " Sensi
MName | Value | Lt | Evaluated Value
Ephi_scan S0 deg S0deg
Stheta_scan 0 deg (deg

Figure 2-29 Project Variables dialog box
8. Click OK to close the project Properties window.

Note When using scan angles in unit cell models, the plane of periodicity (here the array plane)
should be parallel to the global coordinate x-y plane. Although not absolutely mandatory, adhering
to this natural convention insures the simplest and clearest relationship between scan angles and
the structure being modeled.

Use Scan Angles for the Model

Now that you created the scan angle variables, you will apply them to the model. To use themin
the model, perform the following steps.

1. Double-click Slave1 from the Project Tree.
The Slave: General Data dialog box appears.
2. Click Phase Delay and set the fields as shown in following figure.

General Data  Phase Delay l Defaults ]

* |Use Scan Angles To Calculate Phase Delay
Scan Angles

Phi: |5phi_su:an |

=l
Theta: |Stheta_su:an | J

Figure 2-30 Use Scan Angles

3. Click OK.
The scan angles are set and copied in the settings for Slave2.

Note Ignore the following informational message that will appear in the Message Manager window
- “Solutions have been invalidated. Undo to recover.”
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Parametric Sweep of Scan Angle

To illustrate more aspects of the Floquet port interface, we now seek the active reflection coef-
ficient of the array as a function of scan angle. When the scan direction is in the E-plane of the
array, the array exhibits a nice example of scan blindness at an angle of 27.5 degrees. To demon-
strate this and other phenomena, we will set up a parametric sweep to make an E-plane scan from
broadside (scan = 0) to endfire (scan = 90 degrees).

To setup a parametric analysis:
1. Right click Optimetrics and select Add>Parametric.
The Setup Sweep Analysis dialog box appears.
2. Click Add on the Sweep Definitions tab.
The Add/Edit Sweep dialog box appears.

Y ariahble Dreszcription
“Yariable | $theta_zcan j

$theta...  Linear Step from Odeg to 90deg, step=0.5deg
" Single value

* Linear step

" Linear count cuafl B
" Decade count
" Octave count
~

Exponential count

L

Start: ||:| ||:Ieg j
Stop: |EHZI |u:|eg j
Step: |EI.5 ||jeg j Ok Cancel

Figure 2-31 Add/Edit Sweep dialog box

3. Make the entries as in "Add/Edit Sweep dialog box" above. .
4. Click Add >> to include the settings.
5. Click OK.
The Setup Sweep Analysis dialog box lists the $theta _scan variable and its description.
6. Click General to verify the settings are as in following figure.

Sweep Definttions ] Table General lCaIn::uIatin:nns ] Options ]

Sim. Setup | Include | Starting Paoint:
Setup1 [v Deszign ‘v"arial:nle| Dverride| Walue | Llnits|
tphi_zcan mERED deg
$theta_scan 0 deq
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Figure 2-32 Setup Sweep Analysis

7. Click Options.
8. Set the fields as shown in following figure.

Sweep Definitions ] Table ] General ] Calculations ~Cptions

[ Save Fields And Mesh

[ Copy geometrically equivalent meshes

Figure 2-33 Options

9. Click OK to close the dialog box.
Parametric Setup1 is listed under Optimetrics.

Set Up Modes for Parametric Sweep

1. Double-click FloquetPort1 under the Excitations.
The Floquet Port dialog box appears.
2. Click Modes Setup.

Note A pair of modes is adequate for broadside scan. For larger scan angles, additional
modes are required.

3. Click Modes Calculator.

Note The inputs for mode selection do not affect the model set up and so the choices can be
varied to explore different scenarios.

4. Enter 10 for Number of modes for the port. See "Mode Table Calculator” on the facing
page. .

Note Requesting so many modes will give you an idea what modes are necessary and what
are not.

5. Setthe Frequency to 299.97 MHz, which is the actual frequency of simulation.

Note If the problem setup contained one or more frequency sweeps, usually this value is set
to the highest frequency to detect higher-order propagating modes.

6. Enter phi scan angle as 90 degrees in both the Start and Stop fields.

Note To create a set of modes that will be adequate for every scan direction in the para-
metric sweep, the scan angles of the sweep are entered in a start-stop-step format. The
entered angles are spherical polar angles of the global coordinate system.

7. Enter the same values for the Theta fields with Step Size as 0.5. See following figure.
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10.
11.

Mumber of bModes:

Frequency:

Scan Angles:

Fhi
Start

Stop
Step Size

Theta
Start
Stop

Step Size

Click OK.

—

FParameters For Mode Selection

[233.79 IMHz  ~|
|30 deg v
EX ldeg |
g deg 7]
o des ~]
EX deg v
05 deg v

Figure 2-34 Mode Table Calculator

The calculator closes and displays the results in the modes table. See "Floquet Port dialog
open on Modes Setup" on the next page. .

Re-enter 4in the Number of Modes field.
The table gets trimmed to only 4 modes. The reasoning for trimming the modes is given in

the next section.
Click OK.

Right-click Parametric-Setup1 and select Analyze.

HFSS runs the Parametric Sweep.

Note This will take some time.
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General Modes Setup l Post Processing ] 30 Refinement

MNumber of Modes: |'||3'

(Flease click on this button if you want assistance in setting up modes.)

Modes Calculator...

Mode Polarization State | m | n | Attenuation (dbAength)

1 TE 0 0.00
] 2 ™ 0 0 0.00
| 3 |TE 0 1 0.00
] 4 ™ 0 1 0.00
| 5 TE 1 0 60.00
| s TE E 0 60.00
7 |TE 0 1 60.00
8 ™ 1 0 60.00
s ™ 0 1 60.00
] w0 ™ E 0 60.00

Figure 2-35 Floquet Port dialog open on Modes Setup

Mode Selection

In the previous section, you set up the modes using the Modes Calculator which resulted in the
table in Figure 35. This section describes the table and the criteria for mode selection. The atten-
uation (db/length) depends upon the scan angle you set in the Mode Table Calculator. Refer to
Figure 35 and note the following details about the results.

« The original pair of specular modes, TEyg and TMyq remain at the top of the list.

« The attenuation for each of TEyg and TMgq is 0 dB meaning that these modes are propagat-
ing unattenuated in at least one scan direction among those selected in "Mode Table Cal-
culator" on the previous page. .

« A second pair of modes, the TE(,_4 and TM_4 are also propagating unattenuated in at least
one scan direction.

« The six remaining modes experience attenuation of 60 dB per meter over the set of specified
scan directions.
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« Any Floquet modes generated within the 3D portion of the model and propagating toward
the Floquet port must be accounted for in the modes table. Since the first four listed modes
reach the Floquet port unattenuated, we will retain them.

« The remaining modes, with large non-zero attenuation can be excluded from the table. Elim-
inating unnecessary modes increases simulation efficiency and eases interpretation of res-
ults. The next point provides a quantitative justification for the omission of the modes with
non-zero attenuation.

« Because the length of the unit cell is 1.25 meters, any of the last six modes that are gen-
erated at the rectangular aperture experience a minimum attenuation of 1.25 * 60 = 75 dB
by the time they reach the Floquet port plane. In most simulations this is small enough so that
you can neglect such modes.

General Modes Setup l Fost Processing ] 3D Refinement ]

MNumber of Modes: |4

{Please click on this buttan if you want assistance in setting up modes )

Modes Calculator... |

Maode Polarization State | m | n | Attenuation (dbAength)
1 |TE 0 0.00
2 M 0 0 0.00
3 TE 0 1 0.00
4 (M 0 1 0.00

Figure 2-36 Selected Modes

If you compare the last two figures, the list is trimmed from the bottom up and now only the TE,
TMgg, TEq.1, and TMg_4 remain.

Note You can increase the modes by entering a number more than 4 for the exact number to
reappear in the list. Remember to always use the minimum number of modes to ensure simulation
efficiency.

Viewing the Results of Parametric Sweep

Once the simulation is over, the S-matrix elements as a function of scan angle can be examined in
the Matrix Data panel or the Reporter. In Figure 37, the design variation is set for $phi_scan=90
deg and $theta_scan=15 deg. You can click the ellipsis to the right of the Design Variation field
and select 15 deg for $theta_scan from the Set Design Variation dialog box.
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The first column of the S-matrix consists of the array element active reflection coefficient and the
coupling of the Wave port to the various Floquet modes. By viewing the matrix elements for a
sampling of scan angles, it will be immediately noted that the couplings to the TEyg and TE(_4
modes are very small.

Sirnulation; | Setupl j | LaztAdaptive j

Diesign Variation: |$phi_$u:an='9|:|deg' $theta_scan="15deg’

Profile ] Convergence  Matrix Data l Mesh Statistics ]

[v S Matix [ Gamma |299_?E| [MHz] j Export Matriz Data. . |
B YMatr?H | Zo [ Display &l Freqs. |
[ Z Matnx
|Magnitude ﬂ Check Pazsivity |
Pazzivity Tolerance: |.0001

Freq | S:awaveportl | S:awWaveport: 2 | S:FlogquetPaort1:1 | S:FloguetPort1: 2 | 5:FloguetPort1: 3
W Swaveport1 012485 0.00063285  0.0011006 0.99217 335122005
P awavepart2 000041345 0.20484 09758 0.0009086 0.00059451
P FloquetPort11 000056453 0.9788 020483 000084707 000082831
B FloquetPort1:2 0.93217 0.00052647  0.00027932 012459 7.6364e-005
P FloquetPort1:3 7.1236e-005 000081238 0.00081544 42764005  0.0027957
B FloguetPortt:4 0.0010754 000014172 82957e-005  0.0010793 000032524

Figure 2-37 Solutions: Matrix Data

Generate Plots
This section describes how to generate reflection and transmission plots. To create a report show-
ing the (active) reflection and the TM transmission magnitudes plotted as a function of scan angle:

1. Rightclick Results in the Project tree, and from the short cut menu select Create Modal
Solution Data Report> Rectangular Plot.

The Report dialog box appears.
2. Set the fields as shown in following figure.
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‘Context

Solution:

Setupl : LastAdaptive

=}

Trace I Families I Families Displa}rl

Primary Sweep: IEﬂ'nEE_scan ;I I.ﬁ.JI

X v Default I ttheta_scan

W Imag[Sl:FIn:nqueﬂ:‘n:-rtl: 2 Waveport: 1)); maa(S(FloquetPaort1:4, Waveport
Category: Quantity:l filter-text Funct
Variables <nar
Cutput Variables S{FloguetPort1: 2, Waveport: ) ang_
M S(FloquetPort1:3,FloguetPortl:1 ang_
¥ Parameter S(FloguetPort1: 3,FloguetPort1: 2 arg
7 Parameter S{FloguetPort1: 3,FloguetPort1: 3 cang
VSWR S(FloquetPort1:3,FloguetPort1:4 cang
Gamma S(FloguetPort1:3,Waveport: 1) [ |dB
Port Zo S(FloquetPortl:3, Waveport: 2) dB10
Lambda S{FloguetPort1:4,FlaquetPort1: 1 dB20
Epsilon S(FloguetPort1:4,FloguetPort1: 2 dBc
Active 5 Parameter S(FloguetPorti:4, Floguetfortl:3| _| |im
Active ¥ Parameter loguetPort1:4,FloguetPortl:4| = | [HEE
Active Z Parameter 2 3 narm
Active VSWR S(FloquetPortl:4, Waveport: 2) re
Passivity S{Waveport: 1,FloquetPort1: 1)

Design S(Waveport: 1,FloguetPort1:2)

Expression Cache S{Waveport: 1,FloquetPaort1:3)

Expression Converge S{Waveport: 1,FloquetPort1: 4

O O

Figure 2-38 Report dialog box

3. Click New Report.

The new report is displayed.

Note The plot should resemble the one in following figure.
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XY Plot 1 HFSSDesign1 &

000 1000 2000 3000 4000 5000 6000 70.00 8000 900
$theta_scan [deq]

Curve Info

—— maqg(3(FloguetPort1.2 Waveport: 1)
Setup1 : LastAdaptive

Freg=0.29873GHz

—— maq(3(FloguetPort1:4 Waveport: 1))
Setup1 : LastAdaptive

Freg=0.29973GHz

— maglS(Waveport: 1, Waveport: 1))
setup1 : LastAdaptive

Figure 2-39 the plot and the legend

Note Observe that the active reflection coefficient shows the scan blindness condition at
27.5 degrees. Also note that the TMy_4 mode becomes propagating at about 30 degrees and
represents the onset of a grating lobe. Beyond this point, power is about equally split
between the TMyg and TM(_4 modes until the endfire condition is approached.
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3 - Frequency Selective Surface Model

This chapter contains the following topics:
« Sample Project-FSS
« Set Unitand Solution Type
« Create the Unit Cell Model
« Create the Rhombic Sheet
o Transform 2D Sheet into 3D Cell Object
« Position the Rhombus Appropriately
« Create the Aperture
« Move the Aperture to the Rhomboid
» Assign Master and Slave Boundaries
« Assign the Perfect E-Boundary
« Assign the Floquet Ports
o Setup the Analysis
o Add Frequency Sweep
« Run the Simulation
« Generate the Reports
« Phase Transmission Vs Frequency
o S-Parameters Vs Frequency
« Port Field Display for Modes

Sample Project - FSS

You can construct unit cells for frequency selective surface (FSS) simulations using linked bound-
aries and two Floquet ports, with one port above the plane of the structure and the other port under
it. The applied excitations are the Floquet modes themselves, usually one or both specular modes.
As a direct result of the field solution, the reflection and transmission properties of the FSS are cast
in terms of the computed S-matrix entries interrelating the Floquet modes.

This is somewhat in contrast to the simulation setup when PMLs or radiation boundaries are used
to terminate the unit cell. In these cases, in addition to the boundary setup, one or more incident
waves are defined separately as the excitation. The transmission and reflection properties of the
FSS are then automatically computed for the user as a post-processing operation on the field solu-
tion.

We will consider a conducting screen containing a rhombic lattice of circular apertures. The lattice
geometry is shown in "The Lattice Geometry" on the next page. in which, a pair of lattice vectors
are drawn in blue. The angle between the lattice vectors is 60 degrees.
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Figure 3-1 The Lattice Geometry

Consider a plane wave incident normally on the screen with polarization aligned as indicated by
the red arrows in the figure. The transmission loss magnitude and phase as a function of fre-
quency are the quantities of interest. The frequency band is 8 to 20 GHz.
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Figure 3-2 Unit cell for rhombic lattice

Set Units and Solution Type

Set the units and solution type for this project before you design the model.

1.

o gk wd

Open a new Project and name it rhombicArray.

Click Modeler>Units and set the units to cmand click OK.
Insert an HFSS design type.

Click HFSS>Solution Type.

Select Modal.

Click OK.

Create the Unit Cell Model

A simple unit cell model has been created and is shown in "Unit cell for rhombic lattice”" above The
lengths of the side walls are 1.73 cm, the circular aperture diameter is 1.2 cm, and the cellis 4 cm

high. The unit cell clearly is a rhombic object. The section below describes exactly how to draw this
rhombic object.
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Create the Rhombic Sheet

1. Click Draw>Line, click an arbitrary point to set the starting point, and then, click three more
arbitrary points.

2. Returnto close the line by clicking again on the starting point.

3. Right click and select Done from the short-cut menu.
The Properties dialog box appears.

4. Click OK.
This creates an initial Polyline object.

5. Double-click the first CreateLine on the history tree.

First CreateLine Properties dialog box

Mame | Value | Lnit | Evaluated Value
Segment Type | Line
| |Point 1 0.0.0 cm |Ocm . Ocm . Dem
- |Point2 0.865,1.4582 0 cm 0.865cm , 1.4982cm | Ocm

Figure 3-3 Segment tab (1)

6. Enter Point1 and Point2 co-ordinates as in Figure 3.
This moves the first Polyline segment, and gives it the dimensions required.

7. Repeat this process with the next three CreatelLines in the history tree, and edit their Point1
and Point2 co-ordinates as in figures 4 through 6.

This creates the rhombic sheet for the rhombic cell. You may want to make a copy of the
object as afirst step in creating the aperture object.

Second CreateLine Properties dialog box

MName Walue | Unit | Evaluated Value

Segmert Type  Line
Pairt 1 0.865.14582 0 |cm 0.865cm |, 1.4582cm | Ocm
Poirt2 2555 14582 0 |cm 2.555cm |, 1.4982cm |, Ocm

Figure 3-4 Segment tab (2)

Third CreateLine Properties dialog box
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Name Walue | Linit | Evaluated Value |
Segment Type | Line
Pairt 1 2595 14582 .0 |cm 2.595cm , 1.4582cm , Ocm
Foirt2 1.73.0.0 cm 1.73cm , Ocm |, Ocm

Figure 3-5 Segment tab (3)

Fourth CreateLine Properties dialog box

Mame Value | Lnit | Evaluated Value
Segment Type |Line
Pairt 1 173.0.0 cm 1.73cm |, Ocm | Ocm
Pairt2 000 cm Ocm |, Ocm |, Ocm

Figure 3-6 Segment tab (4)

Transform 2-D Sheet into a 3D Cell Object
We recommend, you make a copy of the 2-D sheet because you will need it when you create an
aperture later.
1. Click Polyline1 in the tree to highlight the 2-D sheet.
Do Ctri+C.
Click Polyline to highlight it again.
Click Draw>Sweep>Along Vector.
Input the first point of the sweep vector in the status bar asfollows: X=0,Y=0,Z= 0.

2

Input the second point of the sweep vector as follows:
dx=0,dy=0,dz=4
The Sweep Along Vector dialog box appears.

Draft angle: |EI j | deg ﬂ

Diraft type: | Found ﬂ

] | Canizel |

Figure 3-7 Sweep Along Vector

7. Verify that the Draft angle = 0 and Draft type = Round and click OK.
The Properties dialog box appears.
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MName Walue | Lt | Evaluated Value ||
Command SweepAlongVector
_Ccucurdinate Sys... Global
| Vector 0.0.4 cm |Ocm, Ocm, 4cm
T Draft angle 0 deg |Odeg
T Diraft type Round
T Suppress Com... [

Figure 3-8 Properties dialog box

. Verify that your settings match the ones in "Properties dialog box" above. .
. Click OK.
This completes the sweep converting the 2 D sheet object into a 3-D solid.

Position the Rhombus Appropriately

1. Do Ctri+D to fit the object into the 3-D Modeler window.

. Select the object.

. Click the Move icon on the toolbar.

This lets you enter values in the status bar.

. Input the reference point of the move vector:
« X=0,Y=0,Z2=0.

. Input the target point of the move vector:

o« dx=0,dy=0,dz=-2.0

. Press Enter.

The Properties dialog box appears.

Mame WValue | Lt | Evaluated Value
Command Move
| Coordinate Sys... Global
- |Move Vector 0.0.-2 cm | Ocm, Ocm , -Zem
| Suppress Com... [

Figure 3-9 Move Vector properties

. Click OK.
This moves the rhomboid to the proper position.
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Create the Aperture Object

If the copy of the Polyline that you created before transforming the sheet to a solid, still exists in the
computer memory, then if you go to Edit and click Paste, the sheet will appear in the center of the
3-D object. If it does not exist, then, repeat Steps 1 through 7 from the section “Create Rhombic
Sheet.” Now perform the following steps to create the aperture.

1. Click Draw>Circle.

2. Click the center of the rectangle to produce a round dot under the cursor.

3. Drag the cursor towards the edge of the rectangle and click to draw the circle.
The Properties window opens.

4. Click OK.

5. Double-click CreateCircle on the project tree to open the Properties dialog box and set the
radius as 0.6 cm.

MName | Walue | it | Evaluated Value |
Command CreateCircle
- |Coordinate Sys...|Global
- |Certer Postion 12975 07451 0 cm | 1.2975cm , 074,
| |Aas z
- |Radius 06 cm |0.6cm
N MNumber of Seg... 0 0

Figure 3-10 Circle properties

6. Verify that the circle settings are the same as in "Circle properties" above. .
7. Select both the circle and the rectangle (Polyline2), and click Modeler>Boolean>Subtract.

The Subtract dialog box appears.

Blank Parts - Tool Partz

Palyline2 Circlel

=
—

[ Clone tool objects before operation

Figure 3-11 Subtract dialog box
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8. Verify that Polyline2 is in the BlankParts and Circle1 in the ToolParts.
9. Click OK to close the dialog box.
The circle is subtracted from the rectangle to create the aperture.

Move the Aperture to the Rhomboid

To be sure that the placement of the aperture inside the rhomboid object is accurate, you can
move the aperture and enter the appropriate values in the Properties dialog box for the move vec-
tor.

1. Select the aperture and click Move from the toolbar.
2. Drag the aperture object inside the rhomboid.
3. Double-click Move on the project tree.

The Properties dialog box for the move vector opens.
4. Enter 0, 0, 0in the Move Vector field.

MName | Value | Linit | Evaluated Value
Command Mowe
_Cn:n:nrdinate Sys... Glabal
| Move Vector 000 cm |Ocm , Ocm |, Ocm
| Suppress Com... [

Figure 3-12 Move Vector properties

Assign Master and Slave Boundaries

You have drawn the geometry for the FSS and now you can assign the Master and Slave bound-
aries to the rhomboid object as follows. Refer to "The Master and Slave boundaries applied" on
the facing page. to get a sense of the faces where the U and V vectors are drawn.

1. HitF to enter FaceSelection mode.
2. Select the face shown in following figure, and click HFSS>Boundaries>Assign>Master.
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Figure 3-13 The Master and Slave boundaries applied

The Master Boundary dialog box appears.
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Master Boundary

Mame: [Masterl

Coordinate Spstem

U “ectar: | Indefined ﬂ

IIndefined
Yo wechar:

Cancel

Figure 3-14 Master Boundary dialog box

3. Leave Name as Master1.
4. Select New Vector from the drop-down menu for U.
The Measure dialog box and a the Create Line prompt appear.

5. Click the lower left corner as the starting point on the selected face, and drag the cursor to
the right corner and click.

U-vector is drawn, the V-vector points away from the box, and the Master Boundary dia-
log box appears again.

6. Check Reverse direction for the V-vector, click OK to close the dialog box.
7. Select the opposite face.
8. Click HFSS>Boundaries>Assign Slave.

The Slave dialog box appears.
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Name: |Slavel

Master Boundary: | Master1 j

Coondinate System

U Vector: | Defined ﬂ

WV Vector: | Reverse Direction

Figure 3-15 Slave dialog box after Slave is applied

9. Select Master1 as the Master Boundary and New Vector for U Vector.

10. Draw the U Vector as shown.
Note The U-Vector of the Slave1 will be along the same direction as the U of Master1 (from
the bottom right-most corner of the face to the leftmost corner.)

11. Leave the scan angles at 0 each for Phi and Theta and click Finish.
The Master1 and Slave1 boundaries are created.

12. Repeat the procedure for the Master2 and Slave 2 boundaries, as shown.
Note Make sure you reverse the direction of the V vector as needed. The tail of the U-vector

of Master2 coincides with the head of the U of Master1. Remember that the U-vector of
Slave2 must be along the same direction as that of Master2.
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Figure 3-16 Master2 and Slave2

Assign the Perfect E Boundary

You will now assign a Perfect E boundary to the aperture.

o DN =~

Hit O to enter Object Selection mode.
Select the aperture.
Select HFSS>Boundaries>Assign>Perfect E.

Leave the Name as PerfE1, Infinite Ground Plane deselected and click OK to close the
dialog box.

The PerfE1 boundary appears on the aperture as shown in following figure.
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=
<P
=

Assign the Floquet Ports

Figure 3-17 PerfE1 applied

You are all set to assign the Floquet ports to the top and bottom faces of the model.
1. Select the top face of the model, and click HFSS>Excitations>Assign>Floquet Port
The Floquet Port wizard appears.
2. For the Lattice Coordinate System, from the drop down menu for A direction, select New
Vector.

The Measure Data dialog appears, and the Create Line dialog tells you to draw the A lattice
vector on the plane of the face.
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Figure 3-18 Floquet Port applied
3. Draw the “a” vector parallel to the X axis and then, click.
Note Click the corner along the Z-axis first and then, draw the “a” vector.
The Floquet Port dialog box appears.

Note When you make the second click to complete the vector, the Measure Data and
Create line dialogs disappear, and the Floquet Port wizard reappears, showing that the a
vector is Defined.

4. Select New Vectorfrom the B Direction drop-down menu and draw the “b” vector as
shown.

Note The “b” vector should be perpendicular to “a” and parallel to Y axis.

The “b” vector is drawn and the Modes Setup tab opens.
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5. Click Modes Calculator for assistance in setting up the modes.

Mumber of Modes: 20

Parameters For Maode Selection

Frequency: |2EI |I3Hz j
Scan Angles:
Phi
Start |0 |E|EEI ﬂ
e 0 deg v
StepSize |0 |deg ﬂ
Theta
Start |0 |E|EEI ﬂ
e 0 deg v
Step Size ||:| |deg ﬂ

Figure 3-19 Mode Table Calculator

The Modes calculator appears.
6. Enterthe settings as shown in "Mode Table Calculator" above. .
7. Click OK to close the Calculator.

This fills out the table with calculated values.
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Mode Polarization State | m | n | Attenuation (dbAength)

1 TE 0 | 0 0.00
2 0 0 0.00
| 3 TE 1 0 115
| 4 TE 1 0 115
| 5 TE 4 115
| s |TE 1 1 115
7 ™ 1 1 115
8 m 1 0 115
| 3 ™ 4 115
Sl 10w 1 0 115
o1 TE R 116
| 12 TE 0 1 116
13 ™ R 116
1w 0 1 116
| 15 TE 21 51.53
| . [TE 2 5153
17 ™ 21 51.53
Sl 1w 2 5153
| 19 TE 1 51.53
| = [TE 1 1 5153

Figure 3-20 Calculated Attenuation values
8. Re-enter 14inthe Number of Modes field.
Note The reasoning for trimming the modes is given in the next section.

9. Click Next.
The Post Processing dialog box appears.
10. Check the box for Deembed, and specify the Distance as 2.0 cm.

Deembed Settings

[v Deembed Distance: |2 ||:m ﬂ

Posttive distance will deembed into the port.

Get Distance Graphically... |

Figure 3-21 Post Processing
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11.
12.
13.

14.

Click Next for the 3D Refinement page.

For Mode 1, click the Affects Refinement check box.

Click Finish.

The first Floquet port appears under the Excitations icon in the Project tree.

Select the bottom face of the model, and repeat the proeess to setup the second Floquet
port.

Note Verify that the information from the first Floquet port is copied over.

Omission of Modes with Large Attenuation

In the previous section, we trimmed the table (in Figure 20) from 20 to 14. Since the attenuation for
more than 14 modes is significantly high, we eliminated those modes. For Deembed distance =
2cm, the total attenuation from the aperture to the port = (51.53db/cm)*(2cm) = 103.06db. This is
very large and so we neglect modes through 15 to 20.

Setup the Analysis

1.

Right click Analysis in the project tree, and select Add Solution Setup.

This opens the Solution Setup dialog.

General lOptiu:uns ] Advanced ] Expression Cache ] Denvatives

Setup Name: |Setup1

[+ Enabled [ Solve Ports Only

Solution Frequency: |2I3.I |GH2 j

Adaptive Solutions

Maximum Mumber of Passes: |10

{« Maximum Delta 5 0.02

" Use Matrix Convergence

Figure 3-22 Solution Setup

2. Enter the settings as shown in "Solution Setup" above. .

3. Click Options and enter the setting as shown in following figure.
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General Options lf-‘-dvanu:ed] Expression Cache | Dervatives | Defautt:

Initial Mesh Options
[+ Do Lambda Refinement
Lambda Target: |0.2 [ Use Default Value

| Use Free Space Lambda

Adaptive Options
Maximum Refinemert Per Pass: 30 %
[ Maxdimum Refinement: 1000000

Minimum Mumber of Passes: B
Minimum Converged Passes: 2

Solution Options

Order of Basis Functions: |F|rst Order j

[ Enable terative Solver

[ Enable Use of Solver Domains

Figure 3-23 Options tab
4. Click OK.

Add Frequency Sweep

1. Right-click Setup1 in the Project tree, and select Add Fregquency Sweep.
The Edit Frequency Sweep dialog box appears.
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Edit Frequency Sweep | 2
General l Interpolation ] Defaults ]
Sweep Name: |Sweep [v Enabled
Sweep Type: |Ir|ter|:n:|lating ﬂ
Frequency Sweeps [61 points defined]
Distrbution | Start | End |
1 |Linear Step 8GHz 20GHz Step size 0,2GHz
| | | Preview ... |
Time Domain Calculation... |

QK Cancel

Figure 3-24 Edit Frequency Sweep dialog box

2. Enter the field settings as shown in "Edit Frequency Sweep dialog box" above

3. Click Interpolation and set fields as in following figure.

General  Interpolation l DC Extrapolation ] Defaults ]

T

Max Solutions:

Emor Tolerance:

Advanced Options...

Figure 3-25 Interpolation tab
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4. Click Advanced Options.
Interpolating Sweep Advanced Options dialog appears.

Interpolating Sweep Advanced Cptions

|nterpalation Bazis

Mirirnum S olutions: |5
kdirirnum Murmber of Sub B anges: |1
|nterpolation Convergence
" se &l Entries
{+ |lse Selected Entries Select Entries ...
Data Types For Convergence:
[v S M atrix [ Port Impedance

[ Propagation Constants

-

e

| Enforce Passivity

|EI.EIEII:I1

Figure 3-26 Interpolating Sweep Advanced Options

5. Enter the fields as shown in "Interpolating Sweep Advanced Options" above. .
6. Click Select Entries.

The Interpolation Basis Convergence dialog box opens.
7. Select Allfor fields Entry and Mode Selections.

8. Scroll down to select the row FloquetPort2:1, and set the value in the FloquetPort1:1
column on that row to ON.
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B " Interpolation Basis Convergence 2
Entry Selection: |,-'.‘-.II j
Mode 5 election: |.-'.‘-.II j

FI:::quetF'u:urt'I:'Il FloguetPaort1:2 |FI|:|quetF'|:|rt1:3 Flog. =

FloquetPort1:13
FloquetPort1:14
FloquetPort2:1 ]
FloquetPort2:2
FloquetPort2: 3

FloouetPort2: 4 -
4 L] F

Set Clear Clear &l

Figure 3-27 Interpolation Basis Convergence

9. Click OK to close the Interpolation Basis Convergence dialog box, OK to close the Inter-
polating Sweep Advanced Options dialog box, and OK to close the Edit Sweep dialog
box.

10. Click HFSS>Validation Check.
The validation check should yield correct results.
Note For most HFSS projects, do not be alarmed if you see any warnings in the Message
Manager window. Some of these warnings are informational messages only. They may not
always require you to perform any action to deal with the messages. However, for these pro-
jects, the Message Manager must not display any error or warning messages; the Val-
idation Check dialog box must show a tick near each of the listed options, in which case,
you can analyze the design.

11. Right-click Sweep in the Project tree and click Analyze on the shortcut menu.

The simulation starts and finishes after some time.

Generating Reports

Now that you solved your design, you can generate reports for further analysis of the transmission
and reflection of the wave through HFSS.

Phase Transmission Vs Frequency

1. Right click Results and click Create Modal Solution Data Report>Rectangular Plot
from the project tree.

The Report dialog box appears.
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2. The Context portion of the dialog box should resemble the entries in "Context part of the
Report dialog box" below. .

3. Enter the fields for Trace as in "Trace part of the Report dialog box" below. so thatthe Y
axis is populated with the expression for phase transmission.

4. Leave the Default value of X at Freq.

Context

Solution; |Set|_||:|1 : Sweep j
Domain: |5WEEF' ﬂ
Update Report

v Real ime

COutput Variables. .. | Dpﬁons...|

Figure 3-28 Context part of the Report dialog box
5. Click New Report.

X v Default |FI'EIZ| J
. . Range

W |ang_deg|:5|:FIunEﬁ:'Drt2. 1,FloguetPorti: 1)) Funchion...

Category: Quantity:| filter-text Function:

Variables -

Cutput Variables

S{FloguetPort2: 1,FloquetPort1: 2)
S{FloquetPort?: 1, FloquetPort1:3) -
F T b

Y Parameter
Z Parameter

LA

cang_deg =

Figure 3-29 Trace part of the Report dialog box

HFSS generates the plot for Phase Transmission versus Frequency. See following figure.
Clearly, from the plot we can infer that phase changes as the wave passes through the FSS.
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ang_deqg(S(FloguetPort2:1
FIrc:ngvc:TuetBl:c:nrh:1:||§|:I '

Setup1:Sweep

L

=

=

=
]

M
&N
=
=

Phiase decreases as Freq increases |

ang_deg({S(FloguetPort2:1 FloquetPort1:1)) [deaq]

0.00 4
1 |Thephaseisﬂat18
1 GHz

-25.00

5000 ————— et
8.00 10.00 12.00 14.00 16.00 18.00 20.00

Freq [GHZ]

Figure 3-30 Phase Transmission Vs Frequency

S Parameters Vs Frequency

Right-click Create Modal Solution Data Report>Rectangular Plot from the project tree.
Select S Parameter from Category.

Set Y= dB(S(FloquetPort1:1,FloquetPort1:1)) in the Report dialog box.

Setthe Function as dB.

Click New Report.

o~ DN~

The transmission curve is generated.
6. ChangeY to dB(S(FloquetPort1:1,FloquetPort2:1))
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XY Plot 4 HFSSDesign1 &
0.00 —
!
-10.00 -
-
-20.00 -
p i
-30.00 - Curve Info
- — dB(S(FloguetPortl 1. FlogquetPort1: 1))
4 Setup1 . Sweep
4 —— dB({S(FloguetPort1:1.FlogquetPort2: 1})
Setup1 : Sweep
-40.00 -
L S B e e L B e L e L A o e e e S
2.00 10.00 12.00 14.00 16.00 18.00 20.00
Freq [GHZ]

Figure 3-31 Transmission & Reflection Vs Frequency

7. Click Add Trace.

The second curve is added to the existing trace. Note the strong transmission through the
FSS at 18GHz.

Port Field Displays for Modes

If you double-click the Mode under Floquet Port1 or Floquet Port2 on the Project Tree you can
view the field display for the corresponding mode selected.
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Figure 3-32 Mode 1 Port Display

Figure 3-33 Mode 2 Port Field Display

Figure 3-34 Mode 3 Port Field Display
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Figure 3-35 Mode 4 Port Field Display
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